about summary refs log tree commit diff
path: root/src/nix-store/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/nix-store/Makefile.am')
-rw-r--r--src/nix-store/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/src/nix-store/Makefile.am b/src/nix-store/Makefile.am
index a39d1e2ad985..516d78efc5c2 100644
--- a/src/nix-store/Makefile.am
+++ b/src/nix-store/Makefile.am
@@ -1,15 +1,13 @@
 bin_PROGRAMS = nix-store
 
-nix_store_SOURCES = nix.cc dotgraph.cc
+nix_store_SOURCES = main.cc dotgraph.cc
 nix_store_LDADD = ../libmain/libmain.a ../libstore/libstore.a ../libutil/libutil.a \
  ../boost/format/libformat.a -L../../externals/inst/lib -ldb_cxx -lATerm
 
-nix.o: nix-help.txt.hh
+main.o: help.txt.hh
 
 %.hh: %
-	echo -n '"' > $@
-	sed 's|\(.*\)|\1\\n\\|' < $< >> $@
-	echo '"' >> $@
+	../bin2c/bin2c helpText < $< > $@ || (rm $@ && exit 1)
 
 AM_CXXFLAGS = \
  -I.. -I../../externals/inst/include -I../libutil -I../libstore -I../libmain