about summary refs log tree commit diff
path: root/src/nix-store/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/nix-store/Makefile.am')
-rw-r--r--src/nix-store/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/nix-store/Makefile.am b/src/nix-store/Makefile.am
new file mode 100644
index 000000000000..a39d1e2ad985
--- /dev/null
+++ b/src/nix-store/Makefile.am
@@ -0,0 +1,27 @@
+bin_PROGRAMS = nix-store
+
+nix_store_SOURCES = nix.cc dotgraph.cc
+nix_store_LDADD = ../libmain/libmain.a ../libstore/libstore.a ../libutil/libutil.a \
+ ../boost/format/libformat.a -L../../externals/inst/lib -ldb_cxx -lATerm
+
+nix.o: nix-help.txt.hh
+
+%.hh: %
+	echo -n '"' > $@
+	sed 's|\(.*\)|\1\\n\\|' < $< >> $@
+	echo '"' >> $@
+
+AM_CXXFLAGS = \
+ -I.. -I../../externals/inst/include -I../libutil -I../libstore -I../libmain
+
+install-data-local:
+	$(INSTALL) -d $(localstatedir)/nix
+	$(INSTALL) -d $(localstatedir)/nix/db
+	$(INSTALL) -d $(localstatedir)/nix/links
+	rm -f $(prefix)/current
+	ln -sf $(localstatedir)/nix/links/current $(prefix)/current
+	$(INSTALL) -d $(localstatedir)/log/nix
+	$(INSTALL) -d $(prefix)/store
+	$(bindir)/nix-store --init
+
+EXTRA_DIST = *.hh