about summary refs log tree commit diff
path: root/src/nix-log2xml/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/nix-log2xml/Makefile.am')
-rw-r--r--src/nix-log2xml/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/nix-log2xml/Makefile.am b/src/nix-log2xml/Makefile.am
new file mode 100644
index 000000000000..4b6c76c24355
--- /dev/null
+++ b/src/nix-log2xml/Makefile.am
@@ -0,0 +1,17 @@
+bin_PROGRAMS = nix-log2xml
+
+nix_log2xml_SOURCES = log2xml.cc
+
+%.xml: %.log nix-log2xml
+	./nix-log2xml < $< > $@
+
+%.html: %.xml mark-errors.xsl log2html.xsl
+	$(xsltproc) mark-errors.xsl $< | $(xsltproc) log2html.xsl - > $@
+
+LOG2HTML = mark-errors.xsl log2html.xsl treebits.js
+
+EXTRA_DIST = $(LOG2HTML)
+
+install-data-local:
+	$(INSTALL) -d $(DESTDIR)$(datadir)/nix/log2html
+	$(INSTALL_DATA) $(LOG2HTML) $(DESTDIR)$(datadir)/nix/log2html