about summary refs log tree commit diff
path: root/src/nix-hash/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/nix-hash/Makefile.am')
-rw-r--r--src/nix-hash/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/nix-hash/Makefile.am b/src/nix-hash/Makefile.am
index 8609cb2164..154f7a2760 100644
--- a/src/nix-hash/Makefile.am
+++ b/src/nix-hash/Makefile.am
@@ -4,5 +4,10 @@ nix_hash_SOURCES = nix-hash.cc
 nix_hash_LDADD = ../libmain/libmain.a ../libstore/libstore.a ../libutil/libutil.a \
  ../boost/format/libformat.a -L../../externals/inst/lib -ldb_cxx -lATerm
 
+nix-hash.o: help.txt.hh
+
+%.txt.hh: %.txt
+	../bin2c/bin2c helpText < $< > $@ || (rm $@ && exit 1)
+
 AM_CXXFLAGS = \
  -I.. -I../../externals/inst/include -I../libutil -I../libstore -I../libmain