about summary refs log tree commit diff
path: root/src/libutil/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libutil/Makefile.am')
-rw-r--r--src/libutil/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/libutil/Makefile.am b/src/libutil/Makefile.am
index a326060cfea9..4a3523f3be2a 100644
--- a/src/libutil/Makefile.am
+++ b/src/libutil/Makefile.am
@@ -3,7 +3,7 @@ pkglib_LTLIBRARIES = libutil.la
 libutil_la_SOURCES = util.cc hash.cc serialise.cc \
   archive.cc xml-writer.cc immutable.cc
 
-libutil_la_LIBADD = ../boost/format/libformat.la ${aterm_lib} ${sqlite_lib}
+libutil_la_LIBADD = ../boost/format/libformat.la
 
 pkginclude_HEADERS = util.hh hash.hh serialise.hh \
   archive.hh xml-writer.hh types.hh immutable.hh
@@ -11,6 +11,8 @@ pkginclude_HEADERS = util.hh hash.hh serialise.hh \
 if !HAVE_OPENSSL
 libutil_la_SOURCES += \
  md5.c md5.h sha1.c sha1.h sha256.c sha256.h md32_common.h
+else
+libutil_la_LIBADD += @OPENSSL_LIBS@
 endif
 
 AM_CXXFLAGS = -Wall -I$(srcdir)/..