about summary refs log tree commit diff
path: root/src/libutil/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libutil/Makefile.am')
-rw-r--r--src/libutil/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/libutil/Makefile.am b/src/libutil/Makefile.am
new file mode 100644
index 0000000000..46f0a048fe
--- /dev/null
+++ b/src/libutil/Makefile.am
@@ -0,0 +1,14 @@
+noinst_LIBRARIES = libutil.a
+
+libutil_a_SOURCES = util.cc hash.cc archive.cc md5.c aterm.cc
+
+AM_CXXFLAGS = -DSYSTEM=\"@host@\" -Wall -I.. -I../../externals/inst/include
+
+EXTRA_DIST = *.hh *.h
+
+check_PROGRAMS = test-aterm
+
+test_aterm_SOURCES = test-aterm.cc
+test_aterm_LDADD = libnix.a $(LDADD) ../boost/format/libformat.a \
+ -L../../externals/inst/lib -ldb_cxx -lATerm
+