about summary refs log tree commit diff
path: root/src/libutil/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libutil/Makefile.am')
-rw-r--r--src/libutil/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/libutil/Makefile.am b/src/libutil/Makefile.am
index 72abfaa11c1b..9d71b66e6287 100644
--- a/src/libutil/Makefile.am
+++ b/src/libutil/Makefile.am
@@ -1,7 +1,11 @@
 lib_LTLIBRARIES = libutil.la
 
 libutil_la_SOURCES = util.cc util.hh hash.cc hash.hh \
- archive.cc archive.hh aterm.cc aterm.hh \
+ archive.cc archive.hh aterm.cc aterm.hh
+
+if !HAVE_OPENSSL
+libutil_la_SOURCES += \
  md5.c md5.h sha1.c sha1.h sha256.c sha256.h md32_common.h
+endif
 
 AM_CXXFLAGS = -Wall -I.. ${aterm_include}