about summary refs log tree commit diff
path: root/src/libstore/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libstore/Makefile.am')
-rw-r--r--src/libstore/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/libstore/Makefile.am b/src/libstore/Makefile.am
index 31735e8936..7e0f32d1f8 100644
--- a/src/libstore/Makefile.am
+++ b/src/libstore/Makefile.am
@@ -5,7 +5,14 @@ libstore_a_SOURCES = \
  normalise.cc misc.cc normalise.hh \
  globals.cc globals.hh db.cc db.hh \
  references.cc references.hh pathlocks.cc pathlocks.hh \
- gc.cc gc.hh
+ gc.cc gc.hh storeexpr-ast.hh
+
+EXTRA_DIST = storeexpr-ast.def storeexpr-ast.cc
 
 AM_CXXFLAGS = -Wall \
  -I.. ${bdb_include} ${aterm_include} -I../libutil
+
+storeexpr-ast.cc storeexpr-ast.hh: ../aterm-helper.pl storeexpr-ast.def
+	$(perl) ../aterm-helper.pl storeexpr-ast.hh storeexpr-ast.cc < storeexpr-ast.def
+
+storeexpr.cc: storeexpr-ast.hh
\ No newline at end of file