about summary refs log tree commit diff
path: root/src/libnix/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/libnix/Makefile.am')
-rw-r--r--src/libnix/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/libnix/Makefile.am b/src/libnix/Makefile.am
new file mode 100644
index 000000000000..b890ba8c0548
--- /dev/null
+++ b/src/libnix/Makefile.am
@@ -0,0 +1,9 @@
+noinst_LIBRARIES = libnix.a
+
+libnix_a_SOURCES = util.cc hash.cc archive.cc md5.c \
+ store.cc expr.cc normalise.cc exec.cc \
+ globals.cc db.cc references.cc pathlocks.cc
+
+AM_CXXFLAGS = -DSYSTEM=\"@host@\" -Wall -I.. -I../../externals/inst/include
+
+EXTRA_DIST = *.hh *.h test-builder-*.sh