about summary refs log tree commit diff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am56
1 files changed, 1 insertions, 55 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 216d664e88..200ea45fb0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,55 +1 @@
-bin_PROGRAMS = nix nix-hash fix
-check_PROGRAMS = test
-
-
-AM_CXXFLAGS = -DSYSTEM=\"@host@\" -Wall -I.. -I../externals/inst/include $(CXXFLAGS)
-LDADD = -L../externals/inst/lib -ldb_cxx -lATerm -L../boost/format -lformat
-
-nix_SOURCES = nix.cc dotgraph.cc
-nix_LDADD = libshared.a libnix.a $(LDADD)
-
-nix_hash_SOURCES = nix-hash.cc
-nix_hash_LDADD = libshared.a libnix.a $(LDADD)
-
-fix_SOURCES = fix.cc
-fix_LDADD = libshared.a libnix.a $(LDADD)
-
-TESTS = test
-
-test_SOURCES = test.cc
-test_LDADD = libshared.a libnix.a $(LDADD)
-
-
-noinst_LIBRARIES = libnix.a libshared.a
-
-libnix_a_SOURCES = util.cc hash.cc archive.cc md5.c \
- store.cc expr.cc normalise.cc exec.cc \
- globals.cc db.cc references.cc pathlocks.cc
-
-libshared_a_SOURCES = shared.cc
-
-libshared_a_CXXFLAGS = \
- -DNIX_STORE_DIR=\"$(prefix)/store\" \
- -DNIX_DATA_DIR=\"$(datadir)\" \
- -DNIX_STATE_DIR=\"$(localstatedir)/nix\" \
- -DNIX_LOG_DIR=\"$(localstatedir)/log/nix\" \
- $(AM_CXXFLAGS)
-
-nix.o: nix-help.txt.hh
-
-%.hh: %
-	echo -n '"' > $@
-	sed 's|\(.*\)|\1\\n\\|' < $< >> $@
-	echo '"' >> $@
-
-install-data-local:
-	$(INSTALL) -d $(localstatedir)/nix
-	$(INSTALL) -d $(localstatedir)/nix/db
-	$(INSTALL) -d $(localstatedir)/nix/links
-	rm -f $(prefix)/current
-	ln -sf $(localstatedir)/nix/links/current $(prefix)/current
-	$(INSTALL) -d $(localstatedir)/log/nix
-	$(INSTALL) -d $(prefix)/store
-	$(bindir)/nix --init
-
-EXTRA_DIST = *.hh *.h test-builder-*.sh
+SUBDIRS = boost libnix libmain nix nix-hash fix