about summary refs log tree commit diff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3b519aa55d82..a56a0ae0e8e0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,13 +1,16 @@
 bin_PROGRAMS = nix fix
+noinst_PROGRAMS = test
 
 AM_CXXFLAGS = -DSYSTEM=\"@host@\" -Wall
 
-nix_SOURCES = nix.cc db.cc util.cc md5.c
+nix_SOURCES = nix.cc db.cc util.cc hash.cc md5.c
 nix_LDADD = -ldb_cxx-4 -lATerm
 
-fix_SOURCES = fix.cc util.cc md5.c
+fix_SOURCES = fix.cc util.cc hash.cc md5.c
 fix_LDADD = -lATerm
 
+test_SOURCES = test.cc util.cc hash.cc md5.c
+
 install-data-local:
 	$(INSTALL) -d $(localstatedir)/nix
 	$(INSTALL) -d $(localstatedir)/nix/descriptors