about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 3c57826d1a1e..37a936fd2efb 100644
--- a/shell.nix
+++ b/shell.nix
@@ -17,6 +17,10 @@ with import <nixpkgs> {};
       })
       autoreconfHook
       readline
+
+      # For nix-perl
+      perl
+      perlPackages.DBDSQLite
     ];
 
   configureFlags =
@@ -30,6 +34,9 @@ with import <nixpkgs> {};
 
   shellHook =
     ''
-      configureFlags+=" --prefix=$(pwd)/inst"
+      export prefix=$(pwd)/inst
+      configureFlags+=" --prefix=prefix"
+      PKG_CONFIG_PATH=$prefix/lib/pkgconfig:$PKG_CONFIG_PATH
+      PATH=$prefix/bin:$PATH
     '';
 }