about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/shell.nix b/shell.nix
index bbce68564b95..c4e2a20f8fa7 100644
--- a/shell.nix
+++ b/shell.nix
@@ -2,6 +2,8 @@
 
 with import <nixpkgs> {};
 
+with import ./release-common.nix { inherit pkgs; };
+
 (if useClang then clangStdenv else stdenv).mkDerivation {
   name = "nix";
 
@@ -16,17 +18,13 @@ with import <nixpkgs> {};
         customMemoryManagement = false;
       })
       autoreconfHook
-      readline
 
       # For nix-perl
       perl
       perlPackages.DBDSQLite
     ];
 
-  configureFlags =
-    [ "--disable-init-state"
-      "--enable-gc"
-    ];
+  inherit configureFlags;
 
   enableParallelBuilding = true;