about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 966ab0bb08..d1c2b7ad91 100644
--- a/shell.nix
+++ b/shell.nix
@@ -8,7 +8,9 @@ let
     if compiler == "default"
     then pkgs.haskellPackages
     else pkgs.haskell.packages.${compiler}
-  );
+  ).override {
+    overrides = import ./haskell-overlay.nix { inherit nixpkgs; };
+  };
 
   haskellPackages = (
     if withHoogle
@@ -16,6 +18,10 @@ let
       overrides = (self: super: {
         ghc = super.ghc // { withPackages = super.ghc.withHoogle; };
         ghcWithPackages = self.ghc.withPackages;
+        # eww https://github.com/NixOS/nixpkgs/issues/16394
+        generic-arbitrary = pkgs.haskell.lib.appendPatch
+          super.generic-arbitrary
+          [ ./generic-arbitrary-export-garbitrary.patch ];
       });
     }
     else packageSet