about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 000000000000..ef8960b822db
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,14 @@
+{ pkgs ? import <nixpkgs> {}, ... }:
+
+pkgs.mkShell rec {
+  buildInputs = [];
+  # TODO(wpcarro): How does pkgs.mkShell handle exported and non-exported
+  # variable definitions?
+  BRIEFCASE = builtins.toPath ~/briefcase;
+  DEPOT = builtins.toPath ~/depot;
+  NIXPKGS = builtins.toPath ~/nixpkgs;
+  NIX_PATH="nixpkgs=${NIXPKGS}:depot=${DEPOT}:briefcase=${BRIEFCASE}";
+  DESKTOP = "zeno.lon.corp.google.com";
+  LAPTOP = "seneca";
+  CLOUDTOP = "wpcarro.c.googlers.com";
+}