about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/shell.nix b/shell.nix
index aefc492d3d..966ab0bb08 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,8 +1,8 @@
-{ nixpkgs ? import <nixpkgs> {}, compiler ? "ghc865", withHoogle ? true }:
+{ nixpkgs ? import ./nixpkgs.nix {}, compiler ? "ghc865", withHoogle ? true }:
 let
   inherit (nixpkgs) pkgs;
 
-  xan = import ./xanthous.nix;
+  pkg = import ./pkg.nix { inherit nixpkgs; };
 
   packageSet = (
     if compiler == "default"
@@ -21,7 +21,7 @@ let
     else packageSet
   );
 
-  drv = haskellPackages.callPackage xan {};
+  drv = haskellPackages.callPackage pkg {};
 
   inherit (pkgs.haskell.lib) addBuildTools;
 in