about summary refs log tree commit diff
path: root/scratch/haskell-programming-from-first-principles/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'scratch/haskell-programming-from-first-principles/shell.nix')
-rw-r--r--scratch/haskell-programming-from-first-principles/shell.nix12
1 files changed, 5 insertions, 7 deletions
diff --git a/scratch/haskell-programming-from-first-principles/shell.nix b/scratch/haskell-programming-from-first-principles/shell.nix
index 3190e6e75e72..b594a4207e48 100644
--- a/scratch/haskell-programming-from-first-principles/shell.nix
+++ b/scratch/haskell-programming-from-first-principles/shell.nix
@@ -1,10 +1,8 @@
 let
-  pkgs = import <unstable> {};
-in pkgs.mkShell {
-  buildInputs = with pkgs; [
-    (haskellPackages.ghcWithPackages (hpkgs: with hpkgs; [
-      hpkgs.quickcheck-simple
-      hpkgs.checkers
-    ]))
+  briefcase = import <briefcase> {};
+in briefcase.buildHaskell.shell {
+  deps = hpkgs: with hpkgs; [
+    quickcheck-simple
+    checkers
   ];
 }