about summary refs log tree commit diff
path: root/scratch/groceries/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'scratch/groceries/shell.nix')
-rw-r--r--scratch/groceries/shell.nix9
1 files changed, 3 insertions, 6 deletions
diff --git a/scratch/groceries/shell.nix b/scratch/groceries/shell.nix
index c62b86e12832..4d5b412a0884 100644
--- a/scratch/groceries/shell.nix
+++ b/scratch/groceries/shell.nix
@@ -1,8 +1,5 @@
 let
-  pkgs = import <unstable> {};
-in pkgs.mkShell {
-  buildInputs = with pkgs; [
-    (haskellPackages.ghcWithPackages (hpkgs: with hpkgs; [
-    ]))
-  ];
+  briefcase = import <briefcase> {};
+in briefcase.buildHaskell.shell {
+  deps = hpkgs: [];
 }