about summary refs log tree commit diff
path: root/scratch/brilliant/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'scratch/brilliant/default.nix')
-rw-r--r--scratch/brilliant/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/scratch/brilliant/default.nix b/scratch/brilliant/default.nix
new file mode 100644
index 000000000000..83c62a3d2eba
--- /dev/null
+++ b/scratch/brilliant/default.nix
@@ -0,0 +1,25 @@
+let
+  pkgs = import (builtins.fetchGit {
+    url = "https://github.com/NixOS/nixpkgs-channels";
+    ref = "nixos-20.03";
+    rev = "afa9ca61924f05aacfe495a7ad0fd84709d236cc";
+  }) {};
+
+  ghc = pkgs.haskellPackages.ghcWithPackages (hpkgs: [
+    hpkgs.optparse-applicative
+    hpkgs.unordered-containers
+  ]);
+in pkgs.stdenv.mkDerivation {
+  name = "transform-keyboard";
+  buildInputs = [];
+  src = builtins.path {
+    path = ./.;
+    name = "transform-keyboard-src";
+  };
+  buildPhase = ''
+    ${ghc}/bin/ghc ./Main.hs
+  '';
+  installPhase = ''
+    mkdir -p $out && mv Main $out/transform-keyboard
+  '';
+}