about summary refs log tree commit diff
path: root/release-common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'release-common.nix')
-rw-r--r--release-common.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/release-common.nix b/release-common.nix
new file mode 100644
index 000000000000..8047c75bdb74
--- /dev/null
+++ b/release-common.nix
@@ -0,0 +1,21 @@
+{ pkgs }:
+
+rec {
+  sh = pkgs.busybox.override {
+    useMusl = true;
+    enableStatic = true;
+    enableMinimal = true;
+    extraConfig = ''
+      CONFIG_ASH y
+      CONFIG_ASH_BUILTIN_ECHO y
+      CONFIG_ASH_BUILTIN_TEST y
+      CONFIG_ASH_OPTIMIZE_FOR_SIZE y
+    '';
+  };
+
+  configureFlags =
+    [ "--disable-init-state"
+      "--enable-gc"
+      "--with-sandbox-shell=${sh}/bin/busybox"
+    ];
+}