about summary refs log tree commit diff
path: root/pkgs/wallpapers.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/wallpapers.nix')
-rw-r--r--pkgs/wallpapers.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/pkgs/wallpapers.nix b/pkgs/wallpapers.nix
new file mode 100644
index 000000000000..2f15e45113b8
--- /dev/null
+++ b/pkgs/wallpapers.nix
@@ -0,0 +1,21 @@
+# Fetch my wallpapers from git
+with import <nixpkgs> {};
+
+stdenv.mkDerivation {
+  name    = "tazjins-wallpapers-1";
+
+  src = fetchgit {
+    url = "https://git.tazj.in/tazjin/wallpapers.git";
+    rev = "3bce73b605ba5f848cb4e7cc33058a2be3952c68";
+  };
+
+  installPhase = ''
+    mkdir -p $out/share/wallpapers
+    cp -r $src/* $out/share/wallpapers
+  '';
+
+  meta = with stdenv.lib; {
+    description = "tazjin's wallpaper collection";
+    platforms = platforms.all;
+  };
+}