about summary refs log tree commit diff
path: root/pkg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkg.nix')
-rw-r--r--pkg.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/pkg.nix b/pkg.nix
new file mode 100644
index 0000000000..d3b65a64f3
--- /dev/null
+++ b/pkg.nix
@@ -0,0 +1,7 @@
+{ nixpkgs ? import ./nixpkgs.nix {} }:
+let inherit (nixpkgs) pkgs; in
+import (pkgs.haskellPackages.haskellSrc2nix {
+  name = "xanthous";
+  src = ./.;
+  extraCabal2nixOptions = "--hpack";
+})