about summary refs log tree commit diff
path: root/packages.nix
diff options
context:
space:
mode:
Diffstat (limited to 'packages.nix')
-rw-r--r--packages.nix19
1 files changed, 4 insertions, 15 deletions
diff --git a/packages.nix b/packages.nix
index ea76f3183f22..4804aa8ad859 100644
--- a/packages.nix
+++ b/packages.nix
@@ -33,26 +33,15 @@ in {
     # To use the pinned channel, the original package set is thrown
     # away in the overrides:
     config.packageOverrides = oldPkgs: stable // {
+      # Store whole unstable channel in case that other modules need
+      # it (see emacs.nix for example):
+      inherit unstable;
+
       wallpapers = import ./pkgs/wallpapers.nix;
       pulseaudio-ctl = import pkgs/pulseaudio-ctl.nix;
 
       kontemplate = unstable.kontemplate;
       mq-cli = unstable.mq-cli;
-
-      # Override various Emacs packages from unstable:
-      pinnedEmacs = with unstable.emacsPackagesNg; {
-        inherit
-          counsel
-          counsel-tramp
-          exwm
-          ivy
-          ivy-gitlab
-          ivy-hydra
-          ivy-pass
-          markdown-mode
-          markdown-toc
-          swiper;
-      };
       emacs = unstable.emacs; # emacs 26.1
     };
   };