about summary refs log tree commit diff
path: root/overrides/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overrides/default.nix')
-rw-r--r--overrides/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/overrides/default.nix b/overrides/default.nix
new file mode 100644
index 0000000000..2159d45bd0
--- /dev/null
+++ b/overrides/default.nix
@@ -0,0 +1,28 @@
+# This file is used to move things from nested attribute sets to the
+# top-level.
+{ pkgs, ... }:
+
+{
+  buildGo = pkgs.nix.buildGo;
+
+  # These packages must be exposed at the top-level for compatibility
+  # with Nixery.
+  inherit (pkgs.third_party)
+    bashInteractive
+    cacert
+    coreutils
+    iana-etc
+    jq
+    moreutils
+    nano
+    openssl
+    runCommand
+    symlinkJoin
+    writeText;
+
+  # These packages must be exposed for compatibility with buildGo.
+  #
+  # Despite buildGo being tracked in this tree, I want it to be possible
+  # for external users to import it with the default nixpkgs layout.
+  inherit (pkgs.third_party) go ripgrep;
+}