about summary refs log tree commit diff
path: root/overrides/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overrides/default.nix')
-rw-r--r--overrides/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/overrides/default.nix b/overrides/default.nix
new file mode 100644
index 000000000000..8bc49dec475a
--- /dev/null
+++ b/overrides/default.nix
@@ -0,0 +1,13 @@
+# This file is used to move things from nested attribute sets to the
+# top-level.
+{ depot, ... }:
+
+{
+  buildGo = depot.nix.buildGo; # TODO(tazjin): remove this
+
+  # These packages must be exposed for compatibility with buildGo.
+  #
+  # Despite buildGo being tracked in this tree, I want it to be possible
+  # for external users to import it with the default nixpkgs layout.
+  inherit (depot.third_party) go ripgrep;
+}