about summary refs log tree commit diff
path: root/ops/pipelines/depot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/pipelines/depot.nix')
-rw-r--r--ops/pipelines/depot.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/ops/pipelines/depot.nix b/ops/pipelines/depot.nix
new file mode 100644
index 0000000000..40de18b5de
--- /dev/null
+++ b/ops/pipelines/depot.nix
@@ -0,0 +1,21 @@
+# This file configures the primary build pipeline used for the
+# top-level list of depot targets.
+#
+# It outputs a "YAML" (actually JSON) file which is evaluated and
+# submitted to Buildkite at the start of each build. This means we can
+# dynamically configure the pipeline execution here.
+{ depot, pkgs, ... }:
+
+let
+  inherit (builtins) toJSON;
+  inherit (pkgs) writeText;
+
+  # This defines the build pipeline, using the pipeline format
+  # documented on https://buildkite.com/docs/pipelines/defining-steps
+  pipeline.steps = [
+    {
+      command = "nix-build -A ciBuilds.__allTargets";
+      label = "all-targets";
+    }
+  ];
+in writeText "depot.yaml" (toJSON pipeline)