about summary refs log tree commit diff
path: root/ops/nixos/www/code.tvl.fyi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/nixos/www/code.tvl.fyi.nix')
-rw-r--r--ops/nixos/www/code.tvl.fyi.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/ops/nixos/www/code.tvl.fyi.nix b/ops/nixos/www/code.tvl.fyi.nix
index 5ee33f39ca..e16c0512d9 100644
--- a/ops/nixos/www/code.tvl.fyi.nix
+++ b/ops/nixos/www/code.tvl.fyi.nix
@@ -12,6 +12,13 @@
       forceSSL = true;
 
       extraConfig = ''
+        # Serve the rendered Tvix component SVG.
+        #
+        # TODO(tazjin): Implement a way of serving this dynamically
+        location = /about/tvix/docs/component-flow.svg {
+            alias ${config.depot.tvix.docs.svg}/component-flow.svg;
+        }
+
         # Static assets must always hit the root.
         location ~ ^/(favicon\.ico|cgit\.(css|png))$ {
            proxy_pass http://localhost:2448;