about summary refs log tree commit diff
path: root/ops/nixos/www/b.tvl.fyi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/nixos/www/b.tvl.fyi.nix')
-rw-r--r--ops/nixos/www/b.tvl.fyi.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/ops/nixos/www/b.tvl.fyi.nix b/ops/nixos/www/b.tvl.fyi.nix
deleted file mode 100644
index 45f6c6ed5141..000000000000
--- a/ops/nixos/www/b.tvl.fyi.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{ config, ... }:
-
-{
-  imports = [
-    ./base.nix
-  ];
-
-  config = {
-    services.nginx.virtualHosts."b-shortlink" = {
-      serverName = "b";
-      extraConfig = "return 302 https://b.tvl.fyi$request_uri;";
-    };
-
-    services.nginx.virtualHosts."b.tvl.fyi" = {
-      serverName = "b.tvl.fyi";
-      serverAliases = [ "b.tvl.su" ];
-      enableACME = true;
-      forceSSL = true;
-
-      extraConfig = ''
-        # Forward short links to issues to the issue itself (b/32)
-        location ~ ^/(\d+)$ {
-          return 302 https://b.tvl.fyi/issues$request_uri;
-        }
-
-        location / {
-          proxy_pass http://localhost:${toString config.services.depot.panettone.port};
-        }
-      '';
-    };
-  };
-}