about summary refs log tree commit diff
path: root/ops/nixos/whitby/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/nixos/whitby/default.nix')
-rw-r--r--ops/nixos/whitby/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/ops/nixos/whitby/default.nix b/ops/nixos/whitby/default.nix
index 38a9f9a550..68660896cb 100644
--- a/ops/nixos/whitby/default.nix
+++ b/ops/nixos/whitby/default.nix
@@ -15,6 +15,7 @@ let
 in {
   inherit depot;
   imports = [
+    "${depot.depotPath}/ops/nixos/clbot.nix"
     "${depot.depotPath}/ops/nixos/depot.nix"
     "${depot.depotPath}/ops/nixos/smtprelay.nix"
     "${depot.depotPath}/ops/nixos/tvl-slapd/default.nix"
@@ -164,6 +165,27 @@ in {
     };
   };
 
+  # Start the Gerrit->IRC bot
+  services.depot.clbot = {
+    enable = true;
+
+    # Almost all configuration values are already correct (well, duh),
+    # see //fun/clbot for details.
+    flags = {
+      gerrit_host = "cl.tvl.fyi:29418";
+      gerrit_ssh_auth_username = "clbot";
+      gerrit_ssh_auth_key = "/etc/secrets/clbot-key";
+      irc_server = "qwerty.zxcvbnm.ninja:6697";
+
+      notify_branches = "canon,refs/meta/config";
+      notify_repo = "depot";
+
+      # This secret is read from an environment variable, which is
+      # populated from /etc/secrets/clbot
+      irc_pass = "$CLBOT_PASS";
+    };
+  };
+
   environment.systemPackages = with nixpkgs; [
     bb
     curl