about summary refs log tree commit diff
path: root/ops/nixos/monorepo-gerrit.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/nixos/monorepo-gerrit.nix')
-rw-r--r--ops/nixos/monorepo-gerrit.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/ops/nixos/monorepo-gerrit.nix b/ops/nixos/monorepo-gerrit.nix
index 327ff633cb..e963587943 100644
--- a/ops/nixos/monorepo-gerrit.nix
+++ b/ops/nixos/monorepo-gerrit.nix
@@ -1,11 +1,11 @@
 # Gerrit configuration for the TVL monorepo
-{ pkgs, config, lib, ... }:
+{ depot, pkgs, config, lib, ... }:
 
 let
   cfg = config.services.gerrit;
   gerritHooks = pkgs.runCommandNoCC "gerrit-hooks" {} ''
     mkdir -p $out
-    ln -s ${config.depot.ops.besadii}/bin/besadii $out/ref-updated
+    ln -s ${depot.ops.besadii}/bin/besadii $out/ref-updated
   '';
 in {
   services.gerrit = {
@@ -17,12 +17,12 @@ in {
       "hooks"
     ];
 
-    plugins = with config.depot.third_party.gerrit_plugins; [
+    plugins = with depot.third_party.gerrit_plugins; [
       checks
       owners
     ];
 
-    package = config.depot.third_party.gerrit;
+    package = depot.third_party.gerrit;
 
     jvmHeapLimit = "4g";