about summary refs log tree commit diff
path: root/ops/nixos/modules/tvl-slapd/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/nixos/modules/tvl-slapd/default.nix')
-rw-r--r--ops/nixos/modules/tvl-slapd/default.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/ops/nixos/modules/tvl-slapd/default.nix b/ops/nixos/modules/tvl-slapd/default.nix
deleted file mode 100644
index 294a6636d719..000000000000
--- a/ops/nixos/modules/tvl-slapd/default.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-# Configures an OpenLDAP instance for TVL
-#
-# TODO(tazjin): Configure ldaps://
-{ pkgs, config, ... }:
-
-{
-  services.openldap = {
-    enable = true;
-    dataDir = "/var/lib/openldap";
-    suffix = "dc=tvl,dc=fyi";
-    rootdn = "cn=admin,dc=tvl,dc=fyi";
-    rootpw = "{SSHA}yEEO6Ol2W3ritdiJzPSsjOtyPGxWF2JW";
-
-    # Contents are immutable at runtime, and adding user accounts etc.
-    # is done statically in the LDIF-formatted contents in this folder.
-    declarativeContents = builtins.readFile ./contents.ldif;
-
-    # ACL configuration
-    extraDatabaseConfig = ''
-      # Allow users to change their own password
-      access to attrs=userPassword
-        by self write
-        by anonymous auth
-        by users none
-
-      # Allow default read access to other directory elements
-      access to * by * read
-    '';
-  };
-}