about summary refs log tree commit diff
path: root/ops/modules/www/whitby.tvl.fyi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/modules/www/whitby.tvl.fyi.nix')
-rw-r--r--ops/modules/www/whitby.tvl.fyi.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/ops/modules/www/whitby.tvl.fyi.nix b/ops/modules/www/whitby.tvl.fyi.nix
new file mode 100644
index 0000000000..bcd7a76ec4
--- /dev/null
+++ b/ops/modules/www/whitby.tvl.fyi.nix
@@ -0,0 +1,17 @@
+# Redirect whitby.tvl.fyi to the machine configuration.
+
+{
+  imports = [
+    ./base.nix
+  ];
+
+  config.services.nginx.virtualHosts."whitby.tvl.fyi" = {
+    serverName = "whitby.tvl.fyi";
+    serverAliases = [ "whitby.tvl.su" ];
+    enableACME = true;
+
+    extraConfig = ''
+      return 302 https://at.tvl.fyi/?q=%2F%2Fops%2Fmachines%2Fwhitby;
+    '';
+  };
+}