about summary refs log tree commit diff
path: root/ops/modules/www/sanduny.tvl.su.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/modules/www/sanduny.tvl.su.nix')
-rw-r--r--ops/modules/www/sanduny.tvl.su.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/ops/modules/www/sanduny.tvl.su.nix b/ops/modules/www/sanduny.tvl.su.nix
new file mode 100644
index 0000000000..1a60d06fa0
--- /dev/null
+++ b/ops/modules/www/sanduny.tvl.su.nix
@@ -0,0 +1,16 @@
+# Redirect sanduny.tvl.su to the machine configuration.
+
+{
+  imports = [
+    ./base.nix
+  ];
+
+  config.services.nginx.virtualHosts."sanduny.tvl.su" = {
+    serverName = "sanduny.tvl.su";
+    enableACME = true;
+
+    extraConfig = ''
+      return 302 https://at.tvl.fyi/?q=%2F%2Fops%2Fmachines%2Fsanduny;
+    '';
+  };
+}