about summary refs log tree commit diff
path: root/ops/modules/www/grep.tvl.fyi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/modules/www/grep.tvl.fyi.nix')
-rw-r--r--ops/modules/www/grep.tvl.fyi.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/ops/modules/www/grep.tvl.fyi.nix b/ops/modules/www/grep.tvl.fyi.nix
new file mode 100644
index 0000000000..8f16e8ccbd
--- /dev/null
+++ b/ops/modules/www/grep.tvl.fyi.nix
@@ -0,0 +1,22 @@
+# Experimental configuration for manually Livegrep.
+{ config, ... }:
+
+{
+  imports = [
+    ./base.nix
+  ];
+
+  config = {
+    # Short link support (i.e. plain http://at) for users with a
+    # configured tvl.fyi/tvl.su search domain.
+    services.nginx.virtualHosts."grep.tvl.fyi" = {
+      enableACME = true;
+      forceSSL = true;
+
+      locations."/" = {
+        # experimental: manually run Docker container
+        proxyPass = "http://172.17.0.3:8910";
+      };
+    };
+  };
+}