about summary refs log tree commit diff
path: root/ops/modules/tvl-slapd/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/modules/tvl-slapd/default.nix')
-rw-r--r--ops/modules/tvl-slapd/default.nix13
1 files changed, 1 insertions, 12 deletions
diff --git a/ops/modules/tvl-slapd/default.nix b/ops/modules/tvl-slapd/default.nix
index cbfdeff31e..dbcf139338 100644
--- a/ops/modules/tvl-slapd/default.nix
+++ b/ops/modules/tvl-slapd/default.nix
@@ -27,17 +27,6 @@ let
   inherit (depot.ops) users;
 
 in {
-  # Use our patched OpenLDAP derivation which enables stronger password hashing.
-  #
-  # Unfortunately the module for OpenLDAP has no package option, so we
-  # need to override it system-wide. Be aware that this triggers a
-  # *large* number of rebuilds of packages such as GPG and Python.
-  nixpkgs.overlays = [
-    (_: _: {
-      inherit (depot.third_party) openldap;
-    })
-  ];
-
   services.openldap = {
     enable = true;
 
@@ -58,7 +47,7 @@ in {
       };
 
       "cn=schema".includes =
-        map (schema: "${depot.third_party.openldap}/etc/schema/${schema}.ldif")
+        map (schema: "${pkgs.openldap}/etc/schema/${schema}.ldif")
             [ "core" "cosine" "inetorgperson" "nis" ];
     };