about summary refs log tree commit diff
path: root/ops/modules/tvl-cache.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/modules/tvl-cache.nix')
-rw-r--r--ops/modules/tvl-cache.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/ops/modules/tvl-cache.nix b/ops/modules/tvl-cache.nix
new file mode 100644
index 0000000000..4d574821df
--- /dev/null
+++ b/ops/modules/tvl-cache.nix
@@ -0,0 +1,19 @@
+{ config, lib, pkgs, ... }:
+
+{
+  options = {
+    tvl.cache.enable = lib.mkEnableOption "the TVL binary cache";
+  };
+
+  config = lib.mkIf config.tvl.cache.enable {
+    nix = {
+      binaryCachePublicKeys = [
+        "cache.tvl.su:kjc6KOMupXc1vHVufJUoDUYeLzbwSr9abcAKdn/U1Jk="
+      ];
+
+      binaryCaches = [
+        "https://cache.tvl.su"
+      ];
+    };
+  };
+}