about summary refs log tree commit diff
path: root/ops/modules/clbot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/modules/clbot.nix')
-rw-r--r--ops/modules/clbot.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/ops/modules/clbot.nix b/ops/modules/clbot.nix
index 71ff2fbc32..ef4c2ab237 100644
--- a/ops/modules/clbot.nix
+++ b/ops/modules/clbot.nix
@@ -37,7 +37,7 @@ let
 
       serviceConfig = {
         User = "clbot";
-        EnvironmentFile = "/etc/secrets/clbot";
+        EnvironmentFile = cfg.secretsFile;
         Restart = "always";
       };
     };
@@ -55,6 +55,12 @@ in {
       type = with types; listOf str;
       description = "Channels in which to post (generates one unit per channel)";
     };
+
+    secretsFile = mkOption {
+      type = types.str;
+      description = "EnvironmentFile from which to load secrets";
+      default = "/run/agenix/clbot";
+    };
   };
 
   config = mkIf cfg.enable {