about summary refs log tree commit diff
path: root/ops/machines/whitby/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/machines/whitby/default.nix')
-rw-r--r--ops/machines/whitby/default.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/ops/machines/whitby/default.nix b/ops/machines/whitby/default.nix
index 82b3bc37cf..1f146c923e 100644
--- a/ops/machines/whitby/default.nix
+++ b/ops/machines/whitby/default.nix
@@ -203,9 +203,13 @@ in {
   };
 
   # Configure secrets for services that need them.
-  age.secrets = {
-    gerrit-queue.file = depot.path.origSrc + "/ops/secrets/gerrit-queue.age";
-  };
+  age.secrets =
+    let
+      secretFile = name: "${depot.path.origSrc}/ops/secrets/${name}.age";
+    in {
+      clbot.file = secretFile "clbot";
+      gerrit-queue.file = secretFile "gerrit-queue";
+    };
 
   # Automatically collect garbage from the Nix store.
   services.depot.automatic-gc = {