about summary refs log tree commit diff
path: root/ops/kontemplate/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ops/kontemplate/default.nix')
-rw-r--r--ops/kontemplate/default.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/ops/kontemplate/default.nix b/ops/kontemplate/default.nix
index 1190869c3fda..be01f9e4f698 100644
--- a/ops/kontemplate/default.nix
+++ b/ops/kontemplate/default.nix
@@ -12,12 +12,11 @@
 
 { lib, pkgs, ... }:
 
-pkgs.buildGoPackage rec {
+pkgs.buildGoModule rec {
   name = "kontemplate-${version}";
   version = "canon";
   src = ./.;
-  goPackagePath = "github.com/tazjin/kontemplate";
-  goDeps = ./deps.nix;
+
   buildInputs = [ pkgs.parallel ];
 
   # Enable checks and configure check-phase to include vet:
@@ -28,6 +27,8 @@ pkgs.buildGoPackage rec {
     done
   '';
 
+  vendorHash = "sha256-xPGVM2dq5fAVOiuodOXhDm3v3k+ncNLhlk6aCtF5S9E=";
+
   meta = with lib; {
     description = "A resource templating helper for Kubernetes";
     homepage = "http://kontemplate.works/";