about summary refs log tree commit diff
path: root/nix/yants/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/yants/default.nix')
-rw-r--r--nix/yants/default.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/nix/yants/default.nix b/nix/yants/default.nix
index aacc156b43..6da99fa3c8 100644
--- a/nix/yants/default.nix
+++ b/nix/yants/default.nix
@@ -93,6 +93,7 @@ with builtins; let
 in lib.fix (self: {
   # Primitive types
   any      = typedef "any" (_: true);
+  unit     = typedef "unit" (v: v == {});
   int      = typedef "int" isInt;
   bool     = typedef "bool" isBool;
   float    = typedef "float" isFloat;