about summary refs log tree commit diff
path: root/nix/utils/tests/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/utils/tests/default.nix')
-rw-r--r--nix/utils/tests/default.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/nix/utils/tests/default.nix b/nix/utils/tests/default.nix
index 1ba6848607..8a078684f3 100644
--- a/nix/utils/tests/default.nix
+++ b/nix/utils/tests/default.nix
@@ -85,6 +85,8 @@ let
   cheddarStorePath =
     builtins.unsafeDiscardStringContext depot.tools.cheddar.outPath;
 
+  cleanedSource = lib.cleanSource ./.;
+
   storePathNameTests = it "correctly gets the basename of a store path" [
     (assertEq "base name of a derivation"
       (storePathName depot.tools.cheddar) depot.tools.cheddar.name)
@@ -94,6 +96,8 @@ let
       (storePathName "${cheddarStorePath}/bin/cheddar") "cheddar")
     (assertEq "base name of a path"
       (storePathName ../default.nix) "default.nix")
+    (assertEq "base name of a cleanSourced path"
+      (storePathName cleanedSource) cleanedSource.name)
   ];
 in