about summary refs log tree commit diff
path: root/nix/utils/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/utils/default.nix')
-rw-r--r--nix/utils/default.nix17
1 files changed, 0 insertions, 17 deletions
diff --git a/nix/utils/default.nix b/nix/utils/default.nix
index d90dee24af..f65d4712a0 100644
--- a/nix/utils/default.nix
+++ b/nix/utils/default.nix
@@ -1,22 +1,6 @@
 { depot, lib, ... }:
 
 let
-
-  /* Takes an attribute set and adds a meta.targets
-     attribute to it which contains all direct children
-     of the attribute set which are derivations.
-
-     Type: attrs -> attrs
-  */
-  drvTargets = attrs:
-    attrs // {
-      meta = {
-        targets = builtins.filter
-          (x: lib.isDerivation attrs."${x}")
-          (builtins.attrNames attrs);
-      } // (attrs.meta or {});
-    };
-
   /* Get the basename of a store path without
      the leading hash.
 
@@ -186,7 +170,6 @@ let
 
 in {
   inherit
-    drvTargets
     storePathName
     pathType
     isDirectory