about summary refs log tree commit diff
path: root/nix/runTestsuite/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/runTestsuite/default.nix')
-rw-r--r--nix/runTestsuite/default.nix22
1 files changed, 6 insertions, 16 deletions
diff --git a/nix/runTestsuite/default.nix b/nix/runTestsuite/default.nix
index dc8e40f8ad..f9a1560479 100644
--- a/nix/runTestsuite/default.nix
+++ b/nix/runTestsuite/default.nix
@@ -140,23 +140,13 @@ let
   runTestsuite = defun [ string (list ItResult) drv ]
     (name: itResults:
       let
-        goodAss = ass: {
-          good = AssertResult.match ass {
-            yep = _: true;
-            nope = _: false;
-          };
-          x = ass;
+        goodAss = ass: AssertResult.match ass {
+          yep = _: true;
+          nope = _: false;
         };
-        goodIt = it: {
-          inherit (it) it-desc;
-          asserts = partitionTests (ass:
-            AssertResult.match ass {
-              yep = _: true;
-              nope = _: false;
-            }) it.asserts;
-        };
-        goodIts = partitionTests (it: (goodIt it).asserts.err == []);
-        res = goodIts itResults;
+        res = partitionTests (it:
+          (partitionTests goodAss it.asserts).err == []
+        ) itResults;
         prettyRes = lib.generators.toPretty {} res;
       in
         if res.err == []