about summary refs log tree commit diff
path: root/nix/nint/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/nint/default.nix')
-rw-r--r--nix/nint/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/nix/nint/default.nix b/nix/nint/default.nix
new file mode 100644
index 0000000000..0087fc0416
--- /dev/null
+++ b/nix/nint/default.nix
@@ -0,0 +1,16 @@
+{ depot, pkgs, ... }:
+
+let
+  inherit (depot.nix.writers)
+    rustSimpleBin
+    ;
+in
+
+rustSimpleBin
+{
+  name = "nint";
+  dependencies = [
+    depot.third_party.rust-crates.serde_json
+  ];
+}
+  (builtins.readFile ./nint.rs)