about summary refs log tree commit diff
path: root/nix/glesys.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/glesys.nix')
-rw-r--r--nix/glesys.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/nix/glesys.nix b/nix/glesys.nix
new file mode 100644
index 000000000000..b485d2637c67
--- /dev/null
+++ b/nix/glesys.nix
@@ -0,0 +1,24 @@
+{
+  sto-tazserve-1 = { pkgs, config, ... }: {
+    deployment.targetHost = "46.21.106.241";
+
+    # Configure root disk
+    fileSystems."/" = {
+      device = "/dev/disk/by-uuid/edb2a58c-561b-4597-9d88-9886cdfb1eac";
+      fsType = "ext4";
+    };
+
+    # Configure network
+    networking.hostName = "sto-tazserve-1";
+    networking.interfaces.ens32.ip4 = [
+      { address = "46.21.106.241"; prefixLength = 23; }
+    ];
+    networking.defaultGateway = "46.21.106.1";
+    networking.nameservers = [ "195.20.206.80" "195.20.206.81" ];
+
+    imports = [
+      ./configuration.nix
+      ./tazserve.nix
+    ];
+  };
+}