about summary refs log tree commit diff
path: root/nix/buildTypedGo/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/buildTypedGo/default.nix')
-rw-r--r--nix/buildTypedGo/default.nix34
1 files changed, 0 insertions, 34 deletions
diff --git a/nix/buildTypedGo/default.nix b/nix/buildTypedGo/default.nix
deleted file mode 100644
index f135b1ebb4..0000000000
--- a/nix/buildTypedGo/default.nix
+++ /dev/null
@@ -1,34 +0,0 @@
-# SPDX-License-Identifier: Apache-2.0
-#
-# A crude wrapper around //nix/buildGo that supports the Go 2 alpha.
-#
-# The way the alpha is implemented is via a transpiler from typed to
-# untyped Go.
-{ depot, pkgs, ... }:
-
-let
-  inherit (builtins)
-    baseNameOf
-    stringLength
-    substring;
-
-  inherit (depot.nix.buildGo) gpackage program;
-
-  go2goext = file: substring 0 ((stringLength file) - 1) file;
-  go2go = file: pkgs.runCommandNoCC "${go2goext (baseNameOf file)}" {} ''
-    cp ${file} .
-    ${pkgs.go}/bin/go tool go2go translate *.go2
-    mv *.go $out
-  '';
-
-in rec {
-  program = { name, srcs, deps ? [], x_defs ? {} }: depot.nix.buildGo.program {
-    inherit name deps x_defs;
-    srcs = map go2go srcs;
-  };
-
-  package = { name, srcs, deps ? [], path ? name, sfiles ? [] }: depot.nix.buildGo.package {
-    inherit name deps path sfiles;
-    srcs = map go2go srcs;
-  };
-}