about summary refs log tree commit diff
path: root/make/examples/trivial/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'make/examples/trivial/default.nix')
-rw-r--r--make/examples/trivial/default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/make/examples/trivial/default.nix b/make/examples/trivial/default.nix
new file mode 100644
index 0000000000..132245e582
--- /dev/null
+++ b/make/examples/trivial/default.nix
@@ -0,0 +1,8 @@
+let {
+
+  inherit (import ../../lib) compileC link;
+
+  hello = link {objects = compileC {main = ./hello.c;};};
+
+  body = [hello];
+}