about summary refs log tree commit diff
path: root/make/examples/simple-header/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'make/examples/simple-header/default.nix')
-rw-r--r--make/examples/simple-header/default.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/make/examples/simple-header/default.nix b/make/examples/simple-header/default.nix
new file mode 100644
index 000000000000..e943471aaa4c
--- /dev/null
+++ b/make/examples/simple-header/default.nix
@@ -0,0 +1,11 @@
+let {
+
+  inherit (import ../../lib) compileC link;
+
+  hello = link {objects = compileC {
+    main = ./hello.c;
+    localIncludes = [ [./hello.h "hello.h"] ];
+  };};
+
+  body = [hello];
+}