about summary refs log tree commit diff
path: root/make/examples/not-so-simple-header/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'make/examples/not-so-simple-header/default.nix')
-rw-r--r--make/examples/not-so-simple-header/default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/make/examples/not-so-simple-header/default.nix b/make/examples/not-so-simple-header/default.nix
new file mode 100644
index 0000000000..61ded57c82
--- /dev/null
+++ b/make/examples/not-so-simple-header/default.nix
@@ -0,0 +1,14 @@
+let {
+
+  inherit (import ../../lib) compileC link;
+
+  hello = link {programName = "hello"; objects = compileC {
+    main = ./foo/hello.c;
+    localIncludes = [
+      [./foo/fnord/indirect.h "fnord/indirect.h"]
+      [./bar/hello.h "fnord/../../bar/hello.h"]
+    ];
+  };};
+
+  body = [hello];
+}