about summary refs log tree commit diff
path: root/make/examples/not-so-simple-header-auto/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'make/examples/not-so-simple-header-auto/default.nix')
-rw-r--r--make/examples/not-so-simple-header-auto/default.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/make/examples/not-so-simple-header-auto/default.nix b/make/examples/not-so-simple-header-auto/default.nix
new file mode 100644
index 0000000000..9e84b0c28a
--- /dev/null
+++ b/make/examples/not-so-simple-header-auto/default.nix
@@ -0,0 +1,11 @@
+let {
+
+  inherit (import ../../lib) compileC findIncludes link;
+
+  hello = link {programName = "hello"; objects = compileC {
+    main = ./foo/hello.c;
+    localIncludes = "auto";
+  };};
+
+  body = [hello];
+}